System Requirements for Akana Platform 2022.1.x

The following table provides information about the minimum system requirements for running the Akana Platform/Akana API Platform 2022.1.x, and about associated supported technologies, such as API description document formats.

For instructions for installing or upgrading, see Installing the Akana API Platform 2022.1.x or Upgrading Akana API Platform to Version 2020.1.x, 2020.2.x, or 2022.1.x.

For system requirements documents for earlier versions, see System Requirements (all versions) in the documentation set for Akana versions up to 2020.2.x.

Supported Platforms: 2022.1.x

Platform Requirements

Third-Party Technologies/Solutions Supported

Platform Requirements

Name Requirement
Akana Platform Host

Minimum recommended hardware per Akana container:

2Ghz CPU, dual core, 4GB RAM minimum, 6GB recommended.

The above assumes a dedicated CPU for each container.

 

Recommended Operating Systems:

  • Windows Server
    • 2012 R2

      Microsoft support of Windows Server 2012 R2 ends in October 2023.

    • 2016
  • Linux
    • CentOS Linux 7.x
    • Ubuntu 16.x, 18.x
    • Red Hat Enterprise Linux Server 7.4, 8.x.

    In general, any Linux version that supports the Akana Platform JRE compatible versions (see JRE version below) should be operable.

Memory configuration:

Default maximum heap size for all Akana Containers (Java processes): 2048 MB.

Recommended: 4096 MB

JRE version:

  • The Akana Platform is compatible with JRE 1.8 and was shipped with OpenJDK JRE version 1.8.0_265 in 2020.2.0, 1.8.0_275 in 2020.2.1 and later. You can also configure the platform to use an external JRE. Akana is certified on OpenLogic OpenJDK JRE version 1.8.0_382-382 as external JRE. For more information, see Configuring an External JRE.

Client browser for accessing Community Manager developer portal

All themes:

  • Chrome version 70 and later (recommended)
  • Firefox version 72.0 and later
  • Microsoft Edge version 44.18362 and later
Database versions

Akana API Platform 2022.1.x supports the following database versions:

  • MySQL 8.0

    Database driver required: see Database drivers (install doc).

  • Oracle 19c and 21c.

    Restriction: The Akana platform has added certification for Oracle 23c. Due to some limitations with Oracle 23c, however, it is not yet certified with Lifecycle Coordinator, Lifecycle Manager, and Lifecycle Repository, which includes Promotions and Custom Properties.

    Database driver required: see Database drivers (install doc).

  • Microsoft SQL Server:
    • 2016 SP2
    • 2019
  • MongoDB (Windows 64-bit MSI and Linux 64-bit TGZ):
    • 6.0 (from 2022.1.3 onwards)
    • 4.4 (from 2022.1.2 onwards)
    • 4.2.11 or later 4.2.x versions

    To download a MongoDB file for your platform, refer to the MongoDB Downloads website.

Depending on the database type and version that you're using, there might be specific requirements, constraints, or additional steps needed. For details, refer to the Database Notes section of the installation documentation.

Elasticsearch

(Required for Community Manager only)

Supported versions:

  • 8.5.3 (from 2022.1.2 onwards)
  • 7.14.2 (from 2022.1.1 onwards)

Recommended for the standalone Elasticsearch server: 4GB RAM, 25GB disk space

Depending on the usage and the number of objects, more disk space might be needed.

See Installing and Configuring Elasticsearch.

Third-Party Technologies/Solutions Supported

Name Details
API description document formats

The platform supports adding an API by uploading, or otherwise referencing, API description documents in any of the following formats:

For more information, see API Description Language Support (Community Manager developer portal documentation).

Third-party identity and access management (IAM) technologies

OAuth Support:

Any providers that are compliant with the applicable OAuth specification are supported. For example, PingFederate versions 9.3.x and 10.0.x are supported out of the box.

OpenID Connect Support:

Any providers that are compliant with the specification are supported.

SAML Identity System:

SAML Web SSO

Any providers that are compliant with the specification are supported.

SiteMinder

  • R12.0 SP3

Kerberos

  • Supported on Windows Server versions 2012 R2, 2016
Third-party libraries For more information, see Using the Third-Party Libraries.
Kafka version

Kafka version supported: Version 2.2.1.